ligand problem

Viewing 1 reply thread
  • Author
    • #34070
      xiaoqing Gong

      Hello! I was running autogrow4 on Linux with python 3.7.6 and mgltools. I failed when I was running the tutorial, and an error showed that there was a problem with the ligand file. I used the naphthalene_smiles.smi file of the tutorial.

      Traceback (most recent call last):
        File "", line 675, in <module>
        File "/home/cuda/gx/autogrow4-4.0.3/autogrow4-4.0.3/autogrow/", line 83, in main_execute
          smile_file_new_gen, new_gen_ligands_list = operations.populate_generation(vars, current_generation_number)
        File "/home/cuda/gx/autogrow4-4.0.3/autogrow4-4.0.3/autogrow/operators/", line 75, in populate_generation
          vars, generation_num
        File "/home/cuda/gx/autogrow4-4.0.3/autogrow4-4.0.3/autogrow/operators/", line 691, in get_complete_list_prev_gen_or_source_compounds
          raise Exception(printout)
      There were no available ligands in previous generation ranked ligand file.
              Check formatting or if file has been moved.
    • #38575
      Jacob Durrant

      Hi Xiaoqing. Much thanks for your interest in AutoGrow4. It’s difficult to know what exactly is causing the problem based on the provided information, but let me give a few suggestions in case they help. The error might occur when none of the compounds of one generation pass the user-specified filters. You could try increasing the number of crossovers, mutants, etc., to give the program more chances to generate acceptable compounds for advancing to the next generation.

      It could also be that it’s not possible to add fragments to your starting compounds because your fragments (or starting compounds) lack the reactive groups that the AutoGrow4 reaction library requires.

      Another thing to try is to remove the -LipinskiLenientFilter parameter, which could allow more evolving compounds to advance to the next generation.

      Hope this helps,


Viewing 1 reply thread
  • The topic ‘ligand problem’ is closed to new replies.