"No such file or directory" error

Computer-Aided Drug Design at the Durrant Lab Forums Webina "No such file or directory" error

Viewing 7 reply threads
  • Author
    Posts
    • #95104 Reply
      Paul Kavanaugh
      Guest

      Hello,

      I have been trying to perform some docking with a substrate, but every time I attempt to run the enzyme and substrate, I get a "No such file or directory" error. I have tried to run this in both google chrome and on windows edge, but continue to get this error. The enzyme is in pdbqt format and I drew the substrates in the browser as it is a simple substrate. I am a little confused as to what could be causing this error.

      Thank you for the program and your assistance!

    • #95108 Reply
      ikk6
      Keymaster

      Hello.
      It might not be easy to debug, but lets try. After the error is generated, could you please open the browser console (right click anywhere on the page, "inspect", then go to "Console" tab) and run the following command:
      FS.readdir(‘/’)
      And post a screenshot.
      Thank you!

    • #126825 Reply
      Arthur de Fouchier
      Guest

      Hi,

      I’ve been having the same problem.
      I’m using a PDB file of a ~430aa protein obbtained from alphafold. For ligand, I’ve been using PBD or SMILES from a 16 carbon chain molecule with an acetate function.

      I get the no such file or directory error using Firefox, Chrome and Edge from a Windows 10 Pro computer.

      I’ve collected screenshots following your guideline from above. There is 5 of them,. The first one is the result of the command you asked to input. There rest are the messages that appear to me to be webina related.

      Here is a link to a Google Photo album with the screenshots. Let me know if you would like me using a different method of sharing screenshots, for futur user with a smiliar problem.
      https://photos.app.goo.gl/J2f12eYF6GpRK65v7

      Hope that you can help me using your software.

      Best,

      Arthur

    • #129504 Reply
      ikk6
      Keymaster

      Hello.
      Sorry for the delay. How do you start the server? Your browser complains of a CORS error.

    • #130720 Reply
      Jaime Tamayo
      Guest

      Hi, I’m havinng the same problem. When I try to run any docking it shows: No such file or directory error. I tried to putting the command FS.readdir(‘/’) as you said, but it didn’t work. I would really appreciate that you could check it carefully and fix this problem because I have been using this platform for my thesis work for half a year and it always ran normally. Greetings from Lima, Peru.

    • #130760 Reply
      ikk6
      Keymaster

      Hello. What do you mean it didn’t work? What was the output?

    • #130815 Reply
      Santiago Pirela
      Guest

      I have been using Webina since January. And I have never had any issues with it until Today. I upload my PDB Protein, then my ligand in .mol, and it always shows me an error message saying "Error Converting File. Are you sure it is a properly formatted PDBQT file?" I drew my Ligand on Avogadro and I am having problems running the web server. The ligand is very small actually. I would appreciate any help. Greetings from Colombia.

    • #130928 Reply
      Jacob Durrant
      Keymaster

      Hi Paul and Santiago. Can you send me copies of your protein and ligand files? That would help a lot with debugging. I’ll email you separately. Thanks. ~Jacob

Viewing 7 reply threads
Reply To: "No such file or directory" error
Your information: