rdkit error

Viewing 1 reply thread
  • Author
    • #15239

      Hello, I am having a similar issue as reported in the post "Ubuntu"
      I try to run autogrow4 on Ubuntu 20.04.
      rdkit was installed via conda (environment activated with conda activate my-rdkit-env).
      I used the alias Python=Python3 but still I get the error:

      Traceback (most recent call last):
      File "/home/nicola/.autogrow4/autogrow/user_vars.py", line 562, in check_dependencies
      import rdkit
      ModuleNotFoundError: No module named ‘rdkit’

      During handling of the above exception, another exception occurred:

      Traceback (most recent call last):
      File "/home/nicola/.autogrow4/RunAutogrow.py", line 657, in <module>
      vars, printout = load_in_commandline_parameters(INPUTS)
      File "/home/nicola/.autogrow4/autogrow/user_vars.py", line 986, in load_in_commandline_parameters
      File "/home/nicola/.autogrow4/autogrow/user_vars.py", line 578, in check_dependencies
      raise ImportError("You need to install rdkit and its dependencies.")
      ImportError: You need to install rdkit and its dependencies.

      if I run conda list I get the following

      packages in environment at /home/nicola/anaconda3/envs/my-rdkit-env:


      Name Version Build Channel

      rdkit 2018.03.2.0 py36h6bb024c_1 rdkit

      I tried to install rdkit via terminal (python3-rdkit) and the problem persists.
      When I try to run autogrow on a cluster and I load the rdkit module I get the same error.

      can somebody pls help troubleshooting this?
      Nicola P.

    • #15470
      Jacob Durrant

      Hi Nicola. Much thanks for your interest in AutoGrow4. This is definitely a python problem, not an autogrow-specific problem. Somehow the version of python you’re using can’t find the rdkit module. It could have something to do with your alias setup, but I’m not certain.

      Try directly running the same python executable you use for autogrow, and type in "import rdkit". Does it give you the same error?

      You might also try the autogrow4 docker container, which tries to automate the installation of dependencies like these.

      Good luck!

Viewing 1 reply thread
  • The topic ‘rdkit error’ is closed to new replies.